URGENT: Internet Explorer 10 Users Must Upgrade ASAP

thumb Last month, we shared information about Microsoft’s end of support for older versions of Internet Explorer (IE) to make sure you knew that they would be ending support for all but the latest version of IE available for a desktop or server operating system. As a result, we’re recommending that you upgrade to IE 11 or another Shift4-supported browser as soon as possible. If you are an IE user and haven’t already upgraded to version 11, you must do so by February 29, 2016. Here’s why:

  • You May Be Unable to Log In to DOLLARS ON THE NET®
    Since unsupported browsers may not receive necessary security patches, we’ve set February 29 as the lockout date for merchants using IE versions 10 and earlier. This means that if you are not using IE 11 (or another Shift4-supported browser), you will be unable to log in to dollarsonthenet.net as of that date. Shift4 has these safeguards in place to prevent unknown and outdated Web browsers from accessing DOLLARS ON THE NET®. This is not only because old browser versions can hinder you from using some of our more advanced features, but more importantly they lack vital security elements that are included with newer browser versions. But, don’t worry. Upgrading to IE 11 is free! Click here to view system requirements. If an outdated operating system prevents you from upgrading to IE 11, you can find links to download the latest version of another supported Web browser, such as Google Chrome or Mozilla Firefox, here.

  • Lack of Security Updates
    Microsoft delivers regular security updates that help users protect their computers from malicious attacks, including patches to resolve vulnerabilities that can be exploited by malware. To ensure that you are maintaining a secure environment, and to help keep your systems safer, it’s essential to receive and implement these security updates on a regular basis. Because Microsoft ended support for older versions of IE on a significant number of operating systems as of January 12, 2016, you may be unable to receive security updates and technical support until you upgrade. Please review Microsoft’s Support Lifecycle FAQ to find out which version of IE is supported by your operating system.

  • PCI Compliance Issues
    If you are not running a version of IE that is receiving regular security patches, your compliance with the PCI DSS (Payment Card Industry Data Security Standard) may be affected. Requirement 6.2 of the PCI DSS requires merchants to “ensure that all system components and software are protected from known vulnerabilities by installing applicable vendor-supplied security patches” and “install critical security patches within one month of release.” The one-month grace period will soon end. Although Internet Explorer 9 and 10 will still be supported on a few older operating systems (and will therefore remain PCI compliant on those systems), we are urging our merchant customers to upgrade to IE 11 or the latest version of another modern Web browser to keep their systems as secure as possible. So if you haven’t already upgraded, now is definitely the time.

As always, we encourage you to regularly update and patch all of your software solutions to ensure a more secure environment. For example, Microsoft recently delivered their last patch to Windows 8 due to security weaknesses that were discovered in that operating system. To read the most up-to-date information about Microsoft’s product support lifecycles, visit the Microsoft Support Lifecycle page and make note of important dates that relate to the products you use.

If your system limitations absolutely restrict you from upgrading to IE 11, and you cannot switch to another Shift4-supported browser, please reach out to us right away and we may be able to develop a customized solution for your business.

Call our 24/7/365 Customer Support team at 702.597.2480 (option 2) or email support@shift4.com and we’ll be happy to answer your questions and help you address any issues.